ZappBots wishes a warm welcome to everyone.

Especially our visitors from
Savage///Circuits and Parallax!!!


Please take a look our new forums, we hope you register and become an active user.

The ZappBots forums are being run on phpBB 3.1.4 software which is different then the vBulletin used on the Savage///Circuits and Parallax forums.
Therefore, things look and work a little different, especially creating posts and uploading images / attachments.


The important thing is we have a place toTalk, Learn and Showcase our projects.

Fixing my PDB-3 bad buttons

A place to talk about anything about electronics that does not fit in one of the below categories.
User avatar
jknightandkarr
Member
Member
Posts: 223
Joined: Tue May 12, 2015 5:11 pm
Location: Hopelessly lost on the USS-Titanic 968 years from home....
Contact:

Fixing my PDB-3 bad buttons

Postby jknightandkarr » Wed Oct 19, 2016 1:34 pm

Well for quite a while I needed to replace buttons on my Pro Dev Board. It had 3 of 8 buttons have the button come off, I couldn't because I didn't have a hot air station at all.

Image
Buttons 3, 6 & 7 with missing caps.

Image
Old buttons removed using my new hot air station.

Image
Compairing the new buttons with one of the old. Little different, mostly the old has the tabs bent under. New ones stick out. Tried bending tabs under. Over all the buttons tabs are slightly wider, but NOT by much. Decided to put em on anyhow.

Image
Managed to get all 3 new buttons soldered on, and so far, working. left 2 of 3 buttons tabs alone, buttons fit, but little bit off.

Image
Pressed all three buttons, and lights go out. Success!, Almost... Button 6 little crooked. Decided to straighten it. No problem.

Image
ARE YOU FREAKING REALLY SERIOUS???!!! :evil: :shock: The 4 SMD resistor pack's solder melted and blew off. :o Almost lost the package 2 times.... NOT GOOD. :evil: ESP since I have almost NO SMD SOLDERING or WORKING experiance..... PLEASE JUST SHOOT ME NOW!! :roll:

Image
Took me quite a bit of time, and more problems,but FINALLY got it back on and soldered back on using hot air station...... The chip fell OFF the desk and ONTO the FLOOR 2 times!! Thank God that we removed the carpet n put down fake wood floor.. I'd been pretty screwed! BUT will the repair WORK?????? Guess only one way to know......

Image
SUCCESS!!!! All 8 LEDs turn ON, and when buttons pressed, turns off. 8-)

As you can see from the pics, I kinda melted the new buttons some, still function though, so that's good at least, and in the process of the repair, I managed to damage the DIP switch some, so that one now needs redone. I didn't check it for function, but 7 of the 8 switches move, so I should be able to use it for time being. Thankfully its through hole, so I can hot air it from the underside of the pcb n not blow and further SMD chips off the pcb. Obviously I need practice, and hopefully someone more experianced with both hot air stations and working with SMD devices might be able to assist me in doing MUCH better with this in future work.

Joe
Image
My website- Http://titaniceng.altervista.org/

My Facebookhttps://www.facebook.com/TitanicElectronicsGames/

~Owner, Designer & Builder Killer K.A.R.R.
~Starfleet Captain Joe R.
USS-Titanic Registry Number NCC-1513
Launched: Star Date 48509.9 Galaxy Class, Titanic Sub-Class Starship Max Warp: 15.96

User avatar
Savage///Circuits
VIP
VIP
Posts: 404
Joined: Tue May 12, 2015 2:43 pm
Location: Palmyra, NY
Contact:

Re: Fixing my PDB-3 bad buttons

Postby Savage///Circuits » Thu Oct 20, 2016 1:47 pm

:o
Image
I'm only responsible for what I say, not what you understand.

User avatar
jknightandkarr
Member
Member
Posts: 223
Joined: Tue May 12, 2015 5:11 pm
Location: Hopelessly lost on the USS-Titanic 968 years from home....
Contact:

Re: Fixing my PDB-3 bad buttons

Postby jknightandkarr » Thu Oct 20, 2016 5:09 pm

Lol thats what i said.

Joe
Image
My website- Http://titaniceng.altervista.org/

My Facebookhttps://www.facebook.com/TitanicElectronicsGames/

~Owner, Designer & Builder Killer K.A.R.R.
~Starfleet Captain Joe R.
USS-Titanic Registry Number NCC-1513
Launched: Star Date 48509.9 Galaxy Class, Titanic Sub-Class Starship Max Warp: 15.96


Return to “Electronics: General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest